romppainen

Hi,

today I encountered a very strange thing and can't seem to find a solution to this. Spine froze for a while when I copy + pasted keyframes and my rig exploded in one frame (other frames remained intact). Other than that one funny frame everything was fine though, Spine was just acting a bit strange after this so I restarted. After restarting the scene file doesn't show any bones or anything in the viewport, but everything is the in the outliner. I can also see my animations from the preview panel and even edit keyframes, but nothing shows in the viewport, Setup or Animation mode.

Tried with my laptop and the same thing occurs, and here it gets really weird. I'm working on v11 of the same file, and none of the earlier versions work either! Up to this point everything worked like a charm. Now even the older file versions display the same weird, empty screen (attached).
Screenshot.png


Also, if I first open any of these files and then open any other file from other projects they suffer from the same thing, nothing in the viewport. These other files open nicely if I open them before opening any of the v01-11 files. My current project is on the heavy side, it has quite a lot of images and three rigs but it has worked perfectly all the time, no hassle.

A workaround that seems to kinda work is that right after opening Spine I start a new project and import my latest project in. But I always have to do this when I start, so it's not a very good solution. Same problem occurs when I open the file that has the imported stuff in it.

I'm working on a commercial project with quite a tight deadline, so any help appreciated!

Using latest stable Spine (4.0.58)
Lenovo ThinkStation Tiny
Intel(R) Core(TM) i7-7700T CPU @ 2.90GHz 2.90 GHz
NVidia Quadro P600
16GB RAM
Bu mesaja eklenen dosyaları görüntülemek için gerekli yetkilere sahip değilsiniz.
romppainen
  • Mesajlar: 3

Misaki

Sorry for the trouble. Could you send us the project file via email? : contact@esotericsoftware.com
As soon as we receive your project file, we will investigate the problem.
Kullanıcı avatarı
Misaki

Misaki
  • Mesajlar: 566

Nate

Sorry for the delay. Thanks for sending the project! We've fixed the problem in 4.1.15-beta. The issue is that bone Leg_L_Master has zero scale in setup mode. That causes a singularity and wrecks some math, causing havoc for the viewport camera.
Kullanıcı avatarı
Nate

Nate
  • Mesajlar: 11802

romppainen

Ok, thanks for checking it out! I tried to get rid of all the 0 scale bones earlier, but the bug had already happened so it didn't help. I guess with 4.1.15 beta it will be gone.

Had some trouble with 0 scale before (mainly that rendered preview png images turn out empty) so it makes sense. Sometimes I've had projects though, where it isn't a problem to have bone scale at 0.

I think there's been tons of discussion about this earlier, but it's too bad that 0 scale wrecks your math, since that would be the easiest solution for me to get rid of things that I don't want visible. I have multiple "rigs" in the scene, for example the whole character from different angles and completely rigged separate heads from multiple angles in each rig, and switching between them very quickly is a must. Would take ages to animate visibility on each layer. Is there a solution for this kind of a thing?

Anyway, thanks for checking it out and it's a great piece of software you've made. :)
romppainen
  • Mesajlar: 3

Erika

romppainen yazdı:I have multiple "rigs" in the scene, for example the whole character from different angles and completely rigged separate heads from multiple angles in each rig, and switching between them very quickly is a must. Would take ages to animate visibility on each layer. Is there a solution for this kind of a thing?
If they're separate rigs, you can just turn the visibility of the skeleton off. But by the "" I must assume they're actually in the same skeleton, in which case deactivating them temporarily is also a breeze!

Spine Tips: hide tree

Complex skeletons may be crowded with everything visible at once. Right click a bone's visibility dot to hide it and all its child slots and bones, without affecting animations.
To deactivate them permanently in some animations, my advice is to save an animation where you set the keys to turn stuff on and off (you can also do so by seleting all the elements and pressing H) so you can quickly just open that animation, copy all the keys and paste them in the animation you need. You can deactivate export for said animation so it's only there to help you work in the editor!
Kullanıcı avatarı
Erika

Erikari
  • Mesajlar: 3050

romppainen

Hide tree is a great feature and I use it a lot, but it's not animatable. In a case where my character turns her head from front view to side view (heads rigged separately with multiple bones and images, parented to same neck) I'd love to just scale front head (the whole tree) to zero or somehow turn it off in that frame with few clicks. I've scaled to zero without trouble in some projects, but sometimes it causes issues. :) In simpler projects I animate the visibility of the slot/image, which is perfect, but in more complex setups it's too complicated to click through every image.

Thanks!

(EDIT: Oh, and after I wrote my message I understood what you meant by creating an animation with keyframes that turn stuff off. Sounds like something I should try. Still requires a lot of work compared to animating stuff on and off with few clicks, but a nice workaround. Thanks!)
romppainen
  • Mesajlar: 3


Dön Bugs