After updating to the new spine version, any skeletons that consist of multiple png's render incorrectly for me, rendering a jumbled mess seemingly drawn entirely from the first png, instead of the intended skeleton. The project runs on android, and I got the same results on a tablet and a Bluestacks emulator.

I've updated to the spine-cocos2dx runtime for 4.0 in the same way I updated to 3.8, which worked previously. However since that method involved overwriting the files in the "cocos2d/cocos/editor-support/spine" filepath, which is not the recommended way, I ended up following the given instructions under Cocos2d-x v3.x Setup in the github, unfortunately to the same result.

I noticed the export naming scheme for multiple png's seemed to change from "name#" to "name_#", but since the atlas reflects the correct names that seemed like a dead end.

I'm wondering if anyone else has experienced a similar issue or might have some off the cuff advice to steer my debugging in the right direction.
  • Mesajlar: 3

Dön Runtimes