Kner

Hi everyone!
I have a really weird issue with some skins on a project I've been working on.
I have created a gift opening animation, to which I have applied several skins. I needed 2 different box sizes so, to achieve this by using only one animation, I created different skin placeholders for the big boxes, which stay blank while a smaller box skin is selected. In Preview (both in Spine and Unity) everything looks as it is supposed to be. But in runtime, when the big boxes appear, from there on all the skins get mixed up.The selected skin's box is shown correctly and only the lid is random.
Any clue on how to solve this? And preferably keep one animation for all box sizes. Thanks

I am using "Spine 4.0.62" Pro and "Unity 2020.3.27f1"
Bu mesaja eklenen dosyaları görüntülemek için gerekli yetkilere sahip değilsiniz.
Kner
  • Mesajlar: 7

Harald

Is the red lid part of the default skin? Do you have any keys in your animation that change attachments? If so, did you perhaps enable Animation cleanup in the Spine export settings?

How do you assign your skins? Which version of the spine-unity runtime are you using (name of the unitypackage, also listed in the Assets/Spine/version.txt file)?

Could you please send us a minimal Unity project that still demonstrates this problem? You can send it as a zip package to contact@esotericsoftware.com, briefly mentioning this forum thread URL so that we know the context.

A side note: The Runtime screenshot looks as if it has been created in the Spine Editor, not in Unity, right? It would in general be better to show the real behaviour in Unity instead of re-creating something similar in the Editor.
Kullanıcı avatarı
Harald

Harri
  • Mesajlar: 3996

Kner

Harald yazdı:Is the red lid part of the default skin?
No, the default skin is empty and only the lights that come out of the box appear there.
Harald yazdı:Do you have any keys in your animation that change attachments?
No I have different bones with separate skin placeholders that are enabled on each scenario. When "small box" skin is selected, the "big box" skin placeholders (which are on a different bone) are empty.
Harald yazdı:If so, did you perhaps enable Animation cleanup in the Spine export settings?
I had Animation cleanup enabled yes. I tried another export disabling it and the situation now changed. All the small boxes appear correctly on runtime, and the big boxes appear without a lid.
Harald yazdı:How do you assign your skins?
string skinName = "mySkin";
skeleton.Skeleton.SetSkin(skinName);
Harald yazdı:Which version of the spine-unity runtime are you using
version: spine-unity-4.0-2021-08-16.unitypackage

I'll try to provide a minimal unity project for better understanding.
Regarding the side note: yes I get it but atm I cannot share more visual info unfortunately.
Thanks a lot for answering in such detail
Kner
  • Mesajlar: 7


Dön Runtimes