Sebastian

Spine web player blendmodes is not using blendmodes when the backgroundColor of the player is set transparent.
Is there a way to fix it?
Sebastian
  • Mesajlar: 2

ChristinaAug

I am blending multiple animations with a transparent background and it works fine. You probably need to send the devs more infos if you want to be helped
ChristinaAug
  • Mesajlar: 3

Mario

Yes, plus show us a working example to reproduce the issue. Include information on what you expect to see, and what you actually see.
Kullanıcı avatarı
Mario

Mario
  • Mesajlar: 3035

Sebastian

I attached a file to show the problem that I'm having with the blending modes.

The blending modes in Photoshop and Spine2d looks the same, and I'm expecting to have the same result in the canvas rendered with webgl. But unfortunately there are some problems.
Photoshop_Vs_Spine2dWebCanvas.png


I'm assuming because the backgroundColor of the canvas player is set transparent == 0 == Black and that's why it is not working. But do you guys think there is a workaround for it?

Here are the export settings from Spine2d
Export Settings.PNG
Bu mesaja eklenen dosyaları görüntülemek için gerekli yetkilere sahip değilsiniz.
Sebastian
  • Mesajlar: 2

Nate

The blending in your image certainly doesn't look right for "Spine web canvas". Some blending modes, like additive, don't make sense to blend on top of transparent. For example, additive blending over a transparent background will always give you transparent (described ([Spine web player]: bug with translucent player?)[here]). It doesn't make logical sense, so if your background is transparent you probably don't want to use additive blending. Do you get the expected results when your canvas has a background color?
Kullanıcı avatarı
Nate

Nate
  • Mesajlar: 11863


Dön Runtimes